{ "cve": [ "CVE-2023-30581" ], "vulnerable": "16.x || 18.x || 20.x", "patched": "^16.20.1 || ^18.16.1 || ^20.3.1", "ref": "https://nodejs.org/en/blog/vulnerability/june-2023-security-releases/", "overview": "The use of proto in process.mainModule.proto.require() can bypass the policy mechanism and require modules outside of the policy.json definition", "affectedEnvironments": [ "all" ], "severity": "high" }