{ "cve": [ "CVE-2016-2183" ], "ref": "https://github.com/nodejs/node/pull/8714", "vulnerable": "6.x || 5.x || 4.x", "patched": "^6.7.0 || ^4.6.0", "description": "openssl 1.0.2h vulnerabilities", "overview": "SWEET32 is a new attack on older block cipher algorithms that use a block size\nof 64 bits.\n\nAs mitigation, OpenSSL has moved DES-based ciphers from the HIGH to MEDIUM\ngroup. As Node.js includes HIGH, but not MEDIUM, in its default suite, affected\nciphers are no longer included unless the default suite is not used. Node's\ndefault TLS cipher suite can be found in the API documentation.\n\n", "affectedEnvironments": [ "all" ], "severity": "high" }