{ "cve": [ "CVE-2017-3732" ], "vulnerable": "4.x || 5.x || 6.x || 7.x", "patched": "^4.7.3 || ^6.9.5 || ^7.5.0", "ref": "https://nodejs.org/en/blog/vulnerability/openssl-january-2017/", "description": "BN_mod_exp may produce incorrect results on x86_64", "overview": "As noted by the OpenSSL team, the likelihood of being able to craft a practical\nattack that uses this flaw is very low. In addition, Node.js enables\nSSL_OP_SINGLE_DH_USE, further decreasing the chance of a successful exploit of\nthis vulnerability in a Node.js service.\n\nAll active versions of Node.js are affected, but the severity is very low for\nNode.js users.\n\n", "affectedEnvironments": [ "all" ], "severity": "medium" }