id: PYSEC-2026-1139 published: "2026-07-07T11:45:21.009176Z" modified: "2026-07-07T17:23:40.899126Z" aliases: - CVE-2023-37415 - GHSA-4q2q-q5pw-2342 summary: Apache Airflow Apache Hive Provider Improper Input Validation vulnerability details: "Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider.\n\nPatching on top of CVE-2023-35797\nBefore\u00a06.1.2\u00a0the proxy_user option can also inject semicolon.\n\nThis issue affects Apache Airflow Apache Hive Provider: before 6.1.2.\n\nIt is recommended updating provider version to 6.1.2 in order to avoid this vulnerability." affected: - package: name: apache-airflow-providers-apache-hive ecosystem: PyPI purl: pkg:pypi/apache-airflow-providers-apache-hive ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 6.1.2 versions: - 1.0.0 - 1.0.0b1 - 1.0.0b2 - 1.0.0rc1 - 1.0.1 - 1.0.1rc1 - 1.0.2 - 1.0.2rc1 - 1.0.3 - 1.0.3rc1 - 2.0.0 - 2.0.0rc1 - 2.0.0rc2 - 2.0.1 - 2.0.1rc1 - 2.0.1rc2 - 2.0.2 - 2.0.2rc1 - 2.0.3 - 2.0.3rc1 - 2.1.0 - 2.1.0rc1 - 2.2.0 - 2.2.0rc1 - 2.2.0rc2 - 2.3.0 - 2.3.0rc1 - 2.3.1 - 2.3.1rc1 - 2.3.2 - 2.3.2rc1 - 2.3.3 - 2.3.3rc1 - 3.0.0 - 3.0.0rc1 - 3.0.0rc2 - 3.1.0 - 3.1.0rc1 - 4.0.0 - 4.0.0rc1 - 4.0.0rc2 - 4.0.0rc3 - 4.0.1 - 4.0.1rc1 - 4.1.0 - 4.1.0rc1 - 4.1.1 - 4.1.1rc2 - 4.1.1rc3 - 5.0.0 - 5.0.0rc1 - 5.1.0 - 5.1.0rc1 - 5.1.0rc2 - 5.1.1 - 5.1.1rc1 - 5.1.2 - 5.1.2rc1 - 5.1.3 - 5.1.3rc1 - 6.0.0 - 6.0.0rc1 - 6.1.0 - 6.1.0rc1 - 6.1.0rc2 - 6.1.1 - 6.1.1rc1 - 6.1.2rc2 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2023-37415 - type: PACKAGE url: https://github.com/apache/airflow - type: WEB url: https://lists.apache.org/thread/9wx0jlckbnycjh8nj5qfwxo423zvm41k - type: WEB url: http://www.openwall.com/lists/oss-security/2023/07/12/3 - type: PACKAGE url: https://pypi.org/project/apache-airflow-providers-apache-hive - type: ADVISORY url: https://github.com/advisories/GHSA-4q2q-q5pw-2342 severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H