id: PYSEC-2026-1140 published: "2026-07-07T11:45:17.859458Z" modified: "2026-07-07T17:23:41.246042Z" aliases: - CVE-2023-28710 - GHSA-ffj9-4crc-q7wf summary: Apache Airflow Spark Provider vulnerable to improper input validation details: Apache Software Foundation Apache Airflow Spark Provider before 4.0.1 is vulnerable to improper input validation because the host and schema of JDBC Hook can contain `/` and `?` which is used to denote the end of the field. affected: - package: name: apache-airflow-providers-apache-spark ecosystem: PyPI purl: pkg:pypi/apache-airflow-providers-apache-spark ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 4.0.1 versions: - 1.0.0 - 1.0.0b1 - 1.0.0b2 - 1.0.0rc1 - 1.0.1 - 1.0.1rc1 - 1.0.2 - 1.0.2rc1 - 1.0.3 - 1.0.3rc1 - 2.0.0 - 2.0.0rc1 - 2.0.0rc2 - 2.0.1 - 2.0.1rc1 - 2.0.2 - 2.0.2rc1 - 2.0.3 - 2.0.3rc1 - 2.1.0 - 2.1.0rc1 - 2.1.0rc2 - 2.1.1 - 2.1.1rc1 - 2.1.2 - 2.1.2rc1 - 2.1.3 - 2.1.3rc1 - 3.0.0 - 3.0.0rc1 - 3.0.0rc2 - 4.0.0 - 4.0.0rc1 - 4.0.1rc1 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2023-28710 - type: WEB url: https://github.com/apache/airflow/pull/30223 - type: PACKAGE url: https://github.com/apache/airflow - type: WEB url: https://lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2 - type: WEB url: http://www.openwall.com/lists/oss-security/2023/04/07/3 - type: PACKAGE url: https://pypi.org/project/apache-airflow-providers-apache-spark - type: ADVISORY url: https://github.com/advisories/GHSA-ffj9-4crc-q7wf severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N