id: PYSEC-2026-1164 published: "2026-07-07T16:02:53.582186Z" modified: "2026-07-07T17:23:44.215367Z" aliases: - CVE-2025-48912 - GHSA-8w7f-8pr9-xgwj summary: "Apache Superset: Improper authorization bypass on row level security via SQL Injection" details: "An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data.\n\nThis issue affects Apache Superset: before 4.1.2.\n\nUsers are recommended to upgrade to version 4.1.2, which fixes the issue." affected: - package: name: apache-superset ecosystem: PyPI purl: pkg:pypi/apache-superset ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 4.1.2 versions: - 0.34.0 - 0.34.1 - 0.35.1 - 0.35.2 - 0.36.0 - 0.37.0 - 0.37.1 - 0.37.2 - 0.38.0 - 0.38.1 - 1.0.0 - 1.0.1 - 1.1.0 - 1.2.0 - 1.3.0 - 1.3.1 - 1.3.2 - 1.4.0 - 1.4.1 - 1.4.2 - 1.5.0 - 1.5.1 - 1.5.2 - 1.5.3 - 2.0.0 - 2.0.1 - 2.1.0 - 2.1.1 - 2.1.1rc1 - 2.1.1rc2 - 2.1.1rc3 - 2.1.2 - 2.1.3 - 3.0.0 - 3.0.0rc1 - 3.0.0rc2 - 3.0.0rc3 - 3.0.0rc4 - 3.0.1 - 3.0.2 - 3.0.3 - 3.0.4 - 3.1.0 - 3.1.0rc1 - 3.1.0rc2 - 3.1.0rc3 - 3.1.0rc4 - 3.1.1 - 3.1.2 - 3.1.3 - 4.0.0 - 4.0.0rc1 - 4.0.0rc2 - 4.0.1 - 4.0.2 - 4.1.0 - 4.1.0rc2 - 4.1.0rc3 - 4.1.0rc4 - 4.1.1 - 4.1.1rc1 - 4.1.2rc1 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2025-48912 - type: PACKAGE url: https://github.com/apache/superset - type: WEB url: https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135 - type: WEB url: http://www.openwall.com/lists/oss-security/2025/05/30/3 - type: PACKAGE url: https://pypi.org/project/apache-superset - type: ADVISORY url: https://github.com/advisories/GHSA-8w7f-8pr9-xgwj severity: - type: CVSS_V4 score: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N