id: PYSEC-2026-1174 published: "2026-07-07T11:45:27.763672Z" modified: "2026-07-07T17:23:45.047325Z" aliases: - CVE-2023-42505 - GHSA-fgpw-4w69-j256 summary: Apache Superset Exposure of Sensitive Information to an Unauthorized Actor vulnerability details: |- An authenticated user with read permissions on database connections metadata could potentially access sensitive information such as the connection's username. This issue affects Apache Superset before 3.0.0. affected: - package: name: apache-superset ecosystem: PyPI purl: pkg:pypi/apache-superset ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 3.0.0 versions: - 0.34.0 - 0.34.1 - 0.35.1 - 0.35.2 - 0.36.0 - 0.37.0 - 0.37.1 - 0.37.2 - 0.38.0 - 0.38.1 - 1.0.0 - 1.0.1 - 1.1.0 - 1.2.0 - 1.3.0 - 1.3.1 - 1.3.2 - 1.4.0 - 1.4.1 - 1.4.2 - 1.5.0 - 1.5.1 - 1.5.2 - 1.5.3 - 2.0.0 - 2.0.1 - 2.1.0 - 2.1.1 - 2.1.1rc1 - 2.1.1rc2 - 2.1.1rc3 - 2.1.2 - 2.1.3 - 3.0.0rc1 - 3.0.0rc2 - 3.0.0rc3 - 3.0.0rc4 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2023-42505 - type: PACKAGE url: https://github.com/apache/superset - type: WEB url: https://lists.apache.org/thread/bd0fhtfzrtgo1q8x35tpm8ms144d1t2y - type: WEB url: http://www.openwall.com/lists/oss-security/2023/11/28/5 - type: PACKAGE url: https://pypi.org/project/apache-superset - type: ADVISORY url: https://github.com/advisories/GHSA-fgpw-4w69-j256 severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N