id: PYSEC-2026-1177 published: "2026-07-07T11:45:23.589103Z" modified: "2026-07-07T17:23:45.222759Z" aliases: - CVE-2023-39265 - GHSA-fm4q-j8g4-c9j4 summary: Apache Superset Improper Input Validation vulnerability details: Apache Superset would allow for SQLite database connections to be incorrectly registered when an attacker uses alternative driver names like sqlite+pysqlite or by using database imports. This could allow for unexpected file creation on Superset webservers. Additionally, if Apache Superset is using a SQLite database for its metadata (not advised for production use) it could result in more severe vulnerabilities related to confidentiality and integrity. This vulnerability exists in Apache Superset versions up to and including 2.1.0. affected: - package: name: apache-superset ecosystem: PyPI purl: pkg:pypi/apache-superset ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 2.1.1 versions: - 0.34.0 - 0.34.1 - 0.35.1 - 0.35.2 - 0.36.0 - 0.37.0 - 0.37.1 - 0.37.2 - 0.38.0 - 0.38.1 - 1.0.0 - 1.0.1 - 1.1.0 - 1.2.0 - 1.3.0 - 1.3.1 - 1.3.2 - 1.4.0 - 1.4.1 - 1.4.2 - 1.5.0 - 1.5.1 - 1.5.2 - 1.5.3 - 2.0.0 - 2.0.1 - 2.1.0 - 2.1.1rc1 - 2.1.1rc2 - 2.1.1rc3 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2023-39265 - type: PACKAGE url: https://github.com/apache/superset - type: WEB url: https://lists.apache.org/thread/pwdzsdmv4g5g1n2h9m7ortfnxmhr7nfy - type: WEB url: http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html - type: PACKAGE url: https://pypi.org/project/apache-superset - type: ADVISORY url: https://github.com/advisories/GHSA-fm4q-j8g4-c9j4 severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N