id: PYSEC-2026-1179 published: "2026-07-07T11:45:20.100854Z" modified: "2026-07-07T17:23:45.340150Z" aliases: - CVE-2023-25504 - GHSA-fxjg-28fm-pfxh summary: Apache Superset Server-Side Request Forgery vulnerability details: A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1. affected: - package: name: apache-superset ecosystem: PyPI purl: pkg:pypi/apache-superset ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 2.1.0 versions: - 0.34.0 - 0.34.1 - 0.35.1 - 0.35.2 - 0.36.0 - 0.37.0 - 0.37.1 - 0.37.2 - 0.38.0 - 0.38.1 - 1.0.0 - 1.0.1 - 1.1.0 - 1.2.0 - 1.3.0 - 1.3.1 - 1.3.2 - 1.4.0 - 1.4.1 - 1.4.2 - 1.5.0 - 1.5.1 - 1.5.2 - 1.5.3 - 2.0.0 - 2.0.1 references: - type: ADVISORY url: https://nvd.nist.gov/vuln/detail/CVE-2023-25504 - type: PACKAGE url: https://github.com/apache/superset - type: WEB url: https://lists.apache.org/thread/tdnzkocfsqg2sbbornnp9g492fn4zhtx - type: WEB url: http://www.openwall.com/lists/oss-security/2023/04/18/8 - type: PACKAGE url: https://pypi.org/project/apache-superset - type: ADVISORY url: https://github.com/advisories/GHSA-fxjg-28fm-pfxh severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N