id: PYSEC-2024-25 modified: 2024-02-06T00:25:51.550516Z published: 2024-01-30T01:16:00Z aliases: - CVE-2024-22682 details: DuckDB <=0.9.2 and DuckDB extension-template <=0.9.2 are vulnerable to malicious extension injection via the custom extension feature. affected: - package: ecosystem: PyPI name: duckdb purl: pkg:pypi/duckdb ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 0.9.3.dev6 versions: - 0.0.0 - 0.0.2 - 0.0.3 - 0.1.0 - 0.1.1 - 0.1.2 - 0.1.3 - 0.1.5 - 0.1.6 - 0.1.7 - 0.1.8 - 0.1.9 - 0.2.0 - 0.2.1 - 0.2.2 - 0.2.3 - 0.2.4 - 0.2.5 - 0.2.6 - 0.2.7 - 0.2.8 - 0.2.9 - 0.3.0 - 0.3.1 - 0.3.2 - 0.3.3 - 0.3.4 - 0.4.0 - 0.5.0 - 0.5.1 - 0.6.0 - 0.6.1 - 0.7.0 - 0.7.1 - 0.8.0 - 0.8.1 - 0.9.0 - 0.9.1 - 0.9.2 severity: - type: CVSS_V3 score: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H references: - type: EVIDENCE url: https://github.com/Tu0Laj1/database_test - type: WEB url: https://github.com/Tu0Laj1/database_test