id: PYSEC-2026-2085 published: "2026-07-04T02:16:23.603Z" modified: "2026-07-09T10:36:41.968161Z" aliases: - CVE-2026-12252 - GHSA-9r6g-266r-89x4 details: In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files. affected: - package: name: nltk ecosystem: PyPI purl: pkg:pypi/nltk ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 3.9.4 versions: - "0.8" - "0.9" - 0.9.3 - 0.9.4 - 0.9.5 - 0.9.6 - 0.9.7 - 0.9.8 - 0.9.9 - 2.0.1 - 2.0.1rc1 - 2.0.1rc2-git - 2.0.1rc3 - 2.0.1rc4 - 2.0.2 - 2.0.3 - 2.0.4 - 2.0.5 - 2.0b4 - 2.0b5 - 2.0b6 - 2.0b7 - 2.0b8 - 2.0b9 - 3.0.0 - 3.0.0b1 - 3.0.0b2 - 3.0.1 - 3.0.2 - 3.0.3 - 3.0.4 - 3.0.5 - "3.1" - "3.2" - 3.2.1 - 3.2.2 - 3.2.3 - 3.2.4 - 3.2.5 - "3.3" - "3.4" - 3.4.1 - 3.4.2 - 3.4.3 - 3.4.4 - 3.4.5 - "3.5" - 3.5b1 - "3.6" - 3.6.1 - 3.6.2 - 3.6.3 - 3.6.4 - 3.6.5 - 3.6.6 - 3.6.7 - "3.7" - "3.8" - 3.8.1 - "3.9" - 3.9.1 - 3.9.2 - 3.9.3 - 3.9b1 ecosystem_specific: {} references: - type: EVIDENCE url: https://huntr.com/bounties/f5c93982-0cc9-4e2e-bb85-1b6ab29a2efb - type: ADVISORY url: https://github.com/advisories/GHSA-9r6g-266r-89x4 severity: - type: CVSS_V3 score: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H