id: PYSEC-2020-172 details: There is a DoS vulnerability in Pillow before 6.2.2 caused by FpxImagePlugin.py calling the range function on an unvalidated 32-bit integer if the number of bands is large. On Windows running 32-bit Python, this results in an OverflowError or MemoryError due to the 2 GB limit. However, on Linux running 64-bit Python this results in the process being terminated by the OOM killer. affected: - package: name: pillow ecosystem: PyPI purl: pkg:pypi/pillow ranges: - type: ECOSYSTEM events: - introduced: '0' - fixed: 6.2.2 versions: - '1.0' - '1.1' - '1.2' - '1.3' - '1.4' - '1.5' - '1.6' - 1.7.0 - 1.7.1 - 1.7.2 - 1.7.3 - 1.7.4 - 1.7.5 - 1.7.6 - 1.7.7 - 1.7.8 - 2.0.0 - 2.1.0 - 2.2.0 - 2.2.1 - 2.2.2 - 2.3.0 - 2.3.1 - 2.3.2 - 2.4.0 - 2.5.0 - 2.5.1 - 2.5.2 - 2.5.3 - 2.6.0 - 2.6.1 - 2.6.2 - 2.7.0 - 2.8.0 - 2.8.1 - 2.8.2 - 2.9.0 - 3.0.0 - 3.1.0rc1 - 3.1.0.rc1 - 3.1.0 - 3.1.1 - 3.1.2 - 3.2.0 - 3.3.0 - 3.3.1 - 3.3.2 - 3.3.3 - 3.4.0 - 3.4.1 - 3.4.2 - 4.0.0 - 4.1.0 - 4.1.1 - 4.2.0 - 4.2.1 - 4.3.0 - 5.0.0 - 5.1.0 - 5.2.0 - 5.3.0 - 5.4.0.dev0 - 5.4.0 - 5.4.1 - 6.0.0 - 6.1.0 - 6.2.0 - 6.2.1 references: - type: WEB url: https://pillow.readthedocs.io/en/stable/releasenotes/6.2.2.html - type: WEB url: https://usn.ubuntu.com/4272-1/ - type: WEB url: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3DUMIBUYGJRAVJCTFUWBRLVQKOUTVX5P/ - type: ADVISORY url: https://www.debian.org/security/2020/dsa-4631 - type: ADVISORY url: https://github.com/advisories/GHSA-5gm3-px64-rw72 aliases: - CVE-2019-19911 - GHSA-5gm3-px64-rw72 modified: '2020-08-24T17:37:00Z' published: '2020-01-05T22:15:00Z'