id: PYSEC-2022-43017 details: An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli. affected: - package: name: wheel ecosystem: PyPI purl: pkg:pypi/wheel ranges: - type: ECOSYSTEM events: - introduced: "0" - fixed: 0.38.1 versions: - "0.1" - 0.10.0 - 0.10.1 - 0.10.2 - 0.10.3 - 0.11.0 - 0.12.0 - 0.13.0 - 0.14.0 - 0.15.0 - 0.16.0 - 0.17.0 - 0.18.0 - 0.19.0 - "0.2" - 0.21.0 - 0.22.0 - 0.23.0 - 0.24.0 - 0.25.0 - 0.26.0 - 0.27.0 - 0.28.0 - 0.29.0 - "0.3" - 0.30.0 - 0.30.0a0 - 0.31.0 - 0.31.1 - 0.32.0 - 0.32.1 - 0.32.2 - 0.32.3 - 0.33.0 - 0.33.1 - 0.33.4 - 0.33.5 - 0.33.6 - 0.34.0 - 0.34.1 - 0.34.2 - 0.35.0 - 0.35.1 - 0.36.0 - 0.36.1 - 0.36.2 - 0.37.0 - 0.37.1 - 0.38.0 - "0.4" - 0.4.1 - 0.4.2 - "0.5" - "0.6" - "0.7" - "0.8" - "0.9" - 0.9.1 - 0.9.2 - 0.9.3 - 0.9.4 - 0.9.5 - 0.9.6 - 0.9.7 references: - type: PACKAGE url: https://pypi.org/project/wheel/ - type: WEB url: https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18 - type: EVIDENCE url: https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/ - type: ADVISORY url: https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/ - type: ADVISORY url: https://github.com/advisories/GHSA-qwmp-2cf2-g9g6 aliases: - CVE-2022-40898 - GHSA-qwmp-2cf2-g9g6 modified: "2023-05-04T03:49:49.039483Z" published: "2022-12-23T00:15:00Z"