RStudio IDE

CHEATSHEET

Documents and Apps

Open Shiny, R Markdown,
ETEX | knitr, Sweave, LaTeX, .Rd files
and more in Source Pane

rmarkdown

Check  Render Choose Configure Insert
spellrng output output render code  Publish
- format optrons

@] report.Rmd p appR e, 8 SctlptR &  =d

A A 7 Q SQ’Km: - HRun - | B - | =
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+ Jumpto Jump Run Show file  Visual
o previous tonext code  outline  Editor
7 chunk  chunk (reverse
s side)
o Run
B all previous  Run this
5 Jumpto code chunl<§ code chunk

14 section
5 or chunk

16 : . e,
| Setknitr . =5
18  summary(cdrs) chunk -
doar == : .
20 : options

fis (Top Level) & R Markdown =

Access markdown guide at
Help > Markdown Quick Reference
See reverse side for more on Visual Editor

RStudio recognizes that files named app.R,
server.R, ui.R, and global.R belong to a shiny app

@] report.Rmd @ app.R @ script.R =l
Qz-la e » R""Apv..-,@: =

1T :
2T .
3 Run  Choose™" Publishto - Manage
4
. app locationto shinyapps.io publish
6 view app  orserver accounts
1:1 (Top Level) R Script ¢

Source Editor

Tab Panes

Version
memory lﬁtﬁu‘torials CO ntrOl

chunk to server

Console  Terminal

R4.1.0 . ~/Desktop/app/

+3
2+3
+ 4
> View(mtcars)

previous code
asalLocal Job

"POO30QOL!. ..........- Multiple cursors/column selection

"P0030002" .
»BA0Re0a3" with Alt + mouse drag.

"P0030004"

. Hover over diagnostic symbols for details.
get_digit <- functlon() {
("num" %% (10 A n))

Syntax highlighting based
on your file's extension

_Tab completion to finish function
fo names, file paths, arguments, and more.
D for {snippet} Fo;{g{l:variable} in ${2:vector}) {
¢ for {base} |k -
& force  {base} “Multi-language code snippets to

quickly use common blocks of code.

Jump to function in file

(Top Level) * R Séript 2

Workrng Rd’n scriptsin l\/laxirniie,

w/out Echo or outline :
workspace : workspace workspace

Choose environment to display from

Code diagnostics that appear in the margin.

Displays saved objects by

Change file type

R Markdown Jobs -

Path to displayed directory

Directory separate sessions minimize panes
- Ctrl/Cmd + "R Markdown Drag pane ..
to see history  Build Log boundaries

Navigate Openinnew Save Findand Compileas Run Importdata Historyof past Manage  View
backwards/ vvrndovv replace notebook selected  with wizard commandsto  external
forvvards B code : run/copy _databases usage .-
- R —"' lj,_ Go to file ffunction g - - Ad'dins - Rl app ~
®+ report.Rpﬂd . GL app.R o] scrip,t:li. - Environm;‘qt Hi;tory Conn'e:c.tions B_l,lild""b“ Tutorial -
" Source on Save Q / - ’ -}Run °% 4 Source - T 2 B ""Import Dataset ~ % 148 MiB - ;’ List ~
¥ Good Start... e e N fl R - '.j.'(jléb}il'ii'n\'/ironment - i
Re-run =" Source'vvrth or Showfile = : : : i
Load : Save ClearR Searchinside i !

environment - :

Display objects

list of parent environments as list or grid
Data
O df 3 obs. of 2 variables
Values
X 1
Functions
foo function (x)

Viewin'data View function

type with short description viewer source code
Files Plots Packages Help Viewer =
QL New Folder = @ Delete = |Rename {a' More ~
Q Home  Desktop > app: z"PV'" Moré file R
A Name 5 5 opyTO- ; lodified
: woe..  OptiONS
Create Delete Rena me Copy Folder Path to Clipboard Change’
Set As Working Directol .
folder : ! file file o T oo Oertony directory

Open New Terminal Here
Show Folder in New Window

/I 10, 2021, 6:21 PM
Jul 10, 2021, 4:51 PM

@ app.R Show Hidden Files

R! app.Rproj 303 B

A File browser keyed to your working directory.
Click on file or directory name to open.

Turn on at Tools > Project Options > Git/SVN

e D Added @ Modified
G [ Deleted @ Renamed Untracked
Stage  Commit Push/Pull  View  Current
files: staged files toremote  History branch

En‘('ironmem Hlstory Conr!ecnons By}|d-v"(2|t Tutorial -
='oiff = v Commit - o {a' - Za (o branch) ~ -
Staged: Status = Path K
[ .gitignore

W Bm apr Open shell to type commands

Show file diff to view file diﬁerences

Changes | History | (nobranch) ~ (= v Stage = % Revert () Ignbre
Staged Status - Path Commit message
0 gitignore :
] R B
U B0 ap : Amend previous ommit T ——
O app.Rproj .
Show () Staged © Unstaged  Context [ 5lines #)  Ignore Whitespace  «| Stage All = [5] Discard All

@@ -1,13 +1,11 e@ Stage chunk | Discard chunk
i #

2 # This is a Shiny web application. You can run the application by clicking

Package Development

Create a new package with
File > New Project > New Directory > R Package

Enable roxygen documentation with
Tools > Project Options > Build Tools

Roxygen guide at Help > Roxygen Quick Reference

See package information in the Build Tab

Run devtools::load_all()
and reload changes

Install package
and restartR

Environment H:jstory Connections  Build Git  Tutorial =
2] Install and Restart [/] Check  {k More ~
“ LTadA”d oo % Clear output
RunRCMD . Cleamand R and rebuild
CheCk Test Package 08T,
o [v] Check Package O®BE ) 3
CUStOm lZe Build Source Package RU n
package build Build Binary Package package
OpthI’lS -------------------- s Configure Build Tools... tests

posit

RStudio opens plots in a dedicated Plots pane

Files Plots Packages Help Viewer o
» Zoom “5, Publish ~

Navrgate “Openin " Export " Delete " Delete
recent plots window plot plot all plots

GUI Package manager lists every installed package

Files Plots Packages Help Viewer -
Ol install - @ Update
éName % %, Description Version
Install Update Browse
Packages Packages package site
tibble Simple Data Frames 3.1.2 ’

V| tidyr Tidy Messy Data 1.1.3

(:Zlick to load package with Package Delete
library(). Unclick to detach version from
package with detach(). installed  library

RStudio opens documentation in a dedicated Help pane

Files Plots Packages Help Viewer — (=
& D Q ] Refresh Help Topic
R: Render R Markdown +  Find in Topic

Home page of ~ “Search within "Search for
helpful links help file help file

Viewer pane displays HTML content, such as Shiny
apps, RMarkdown reports, and interactive visualizations

Files Plots Packages Help Viewer = =]
C_? ld- - 4, Publish ~
Stop Shiny Publish to shinj/apps.io, Refresh
app Posit Connect, Posit Cloud,...

View(<data>) opens spreadsheet like view of data set

/7 Filter
" mpg cyl disp hp drat | wt qsec vs am
Mazda Rx,l4 21.0 6 160.0 110 3590 2.620 16.46 0 1
Mazda RX4 Wa:g 21.0 6 160.0 110 3590 2.875 17.02 0 1
Filter rows by value Sort by Search
orvalue range values forvalue

Click next to line number to
add/remove a breakpoint.

Run commands in

Step through

Debug Mode

Use debug(), browser(), or a breakpoint and execute
your code to open the debugger mode.

Launch debugger ~ Open traceback to examine
mode from origin  the functions that R called
of error before the error occurred
Console  Terminal ""jo..bs —=
> helloQ) A ;
Error 2" Show Traceback
" & Rerun with Debug

Highlighted line shows where
execution has paused

) painarome.t 01| fottommen Moy | bula G B

7 p'rnmmu whether a positive number is a palindrome  .** B palindrome0~
& palindrome <- function(num) { . Values

®'9 | digits < floor(log(num, 10)) + 1 digitl [
10~ for (x in 1:((digits %/% 2)) { digits 5
1 digitl < get_digit(num, x) - 0000
»12 digit2 <- get_digit(num, (digits + 1 - x) nun 1 o
13 if (digitl |- digit2) = t

14 return(FALSE)

1
16 return(TRUE)
17}

Araceback Show internals =
# palindrome(candidate) at palindrome.R:12

I biggest_palindrome() at palindrome.R:25

Rsarpt £ |+ B

19 # Find the largest palindrome that is the product of two 3-dig
_palindrome <- function() {

(num%%(lﬂ n))%/%(lﬂ (n - 1)) I Fles Plots Packages Help Viewer =0
I QiNewFoider O uplosd © n
Browse[3]> 2 | % Home  iEcheushert ¥
debug at ~/RStudio-Essentials/Essentials-2/palindrome.R#12: d\g\tZ e
- get_digit(num, (digits + 1) - x) B
srcmser21> . ;' ) appR 12K8%  Dec24,2015,9:05 AM

5|

Modified

Examine variables  Select function

environment where in executing in traceback to
execution has paused  environment debug
Console  Terminal Jobs =[]

= Next {“} g— p Continue [l Stop

Resume QlJit debug

Step into and
codeoneline outoffunctions  execution mode
atatime to run
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Keyboard Shortcuts

RUN CODE Windows/Linux Mac

Search command history Ctri+p Cmd+p
Interrupt current command Esc Esc

Clear console Ctrl+L Ctrl+L
NAVIGATE CODE

Go to File/Function Ctrl+. Ctrl+.
WRITE CODE

Attempt completion Tab or Ctrl+Space Tab or Ctrl+Space
Insert <- (assignment operator)  Alt+- Option+-
Insert |> or %>% (pipe operator)  Ctrl+Shift+M Cmd+Shift+M
(Un)Comment selection Ctrl+Shift+C Cmd+Shift+C

MAKE PACKAGES Windows/Linux Mac

DOCUMENTS AND APPS Windows/Linux Mac
Knit/Render Document (knitr)  Ctrl+Shift+K Cmd+Shift+K
Insert chunk (Sweave & Knitr)  Ctrl+Alt+ Cmd+Option+l
Run from start to current line  Ctrl+Alt+B Cmd+Option+B
MORE KEYBOARD SHORTCUTS

Keyboard Shortcuts Help Alt+Shift+K Option+Shift+K

Show Command Palette Ctrl+Shift+P Cmd+Shift+P

View the Keyboard Shortcut Quick
Reference with Tools > Keyboard
Shortcuts or Alt/Option + Shift + K

Search for keyboard shortcuts with
Tools > Show Command Palette
or Ctrl/Cmd + Shift + P.

Keyboard Shortcut Quick Reference H ‘

Tabs Source Navigation

History Send Command to Console

“t.  Switch to Tab...

Load All (devtools) Ctrl+Shift+L Cmd+Shift+L ;"En i Create a New R Script [cer1] [shife| [n]
Test Package (Desktop) Ctrl+Shift+T Cmd+Shift+T b o e Create a new R Markdown document
Document Package Ctrl+Shift+D Cmd+Shift+D 1 e s & s
Vl S u a l Ed |to I Choose Choose Insert Jumpto Jump  Run
Check  Render  output output code previous tonext selected Publish Show file
spelling output  format location chunk chunk chunk lines to server outline
: : : : i = Back to
@ report.Rmd ; ] =[] | .- Source Editor
Block : P ' : " (front page
format : A v Q@ Knit - - - SRun ~ | B - | = ( page)
.................. Heading 2 ~ B I U <« | ¥« @ B Format - Insert - Table ~
; N " ' ' | R Markdown —
- i PoListsand (i i - Including Plots ™" ~File outline
: : Links Citations Images
title: "Document Title" block & : Icrstsaetggtr)]lsocks, “Y nsert and
s n quotes More ° ns, “Insertan
author: "Author Name_g formatting equa'tlons,and edit tables
output: Clear special
html_document: formatting characters
toc: TRUE  Imsert.
verbatim
T code
{r setup, include=FALSE} >
knitr::opts_chunk$set(echo = TRUE)
___________ Add/Edit
R Markdown attributes
This is an R Markdown document.
Markdown is a simple formatting | Run this and
syntax for authoring HTML, PDF, Setknitr  all previous
and MS Word documents. chunk — code chunks
options ,
Run this
Jump to chunk {r cars} B code chunk
or header summary(cars)
" R Markdown = R Markdown %

== posit

Posit
Workbench

WHY POSIT WORKBENCH?

Extend the open source server with a
commercial license, support, and more:

« open and run multiple R sessions at once

« tune your resources to improve performance

« administrative tools for managing user sessions

collaborate real-time with others in shared projects

switch easily from one version of R to a different version

« integrate with your authentication, authorization, and audit practices
« work in the RStudio IDE, JupyterlLab, Jupyter Notebooks, or VS Code

Download a free 45 day evaluation at
posit.co/products/enterprise/workbench/

Share Projects

File > New Project

RStudio saves the call history,
workspace, and working
directory associated with a
project. It reloads each when
you re-open a project.

Close R Session
in project

Start new R Session
incurrent project ..

Sessions~ w?_

BHE garret

% IDEcheatsheet ~

R3.2.2~,

v Rversicr:i 3.2.2
Rversion: 3.1.3
R versiori 3.0.3

Act'ive shared
collaborators

. New Project...

(=d Open Project...

Close Project

Name of

(% Share Project... R versiort'_ 2.15.3
IDEcheatsheet a current
e S B

2| ™ Share Project R Version

shiny-examples

with Collaborators

Clear Project List

Project Options... 088,

Run Remote Jobs

Run R on remote clusters FRun 9 | $ Source -
(Kubernetes/Slurm) via the # Source %8s
Job Launcher Source with Echo 08¢

.{ Source as Launcher Job...

Monitor
launcheriobs...

Launch a JOb [3 Source as Local Job...

Console Launcher =0

4 Start Launcher Job

Terminal Jobs

{Q- Sorted by submission time ~

 fastR Running Local 009 @ O
sleepy.R Succeeded 11:22 AM Local 0:41 S
sleepy.R Idle Waiting @ O

KubernetesX

Run launcher
jobs remotely
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